Jump to content
kurkusmaximus

Black Screen - Battle Realms, W7 Ultimate 64Bit

Recommended Posts

I have:

Windows Ultimate 7 64bit

Phenom 9850BE

XFX 750a

4GB DDR2 1066MHz

Evga 9800GTX+

Tagan BZ700W

Antec 1200

Battle Realms + WOTW

When I run BR I see only black screen with no errors. I have latest drivers for my 9800GTX+. I have this problem in Crysis too. On Vista Ultimate 64bit everything works fine.

Sorry for my bad english.

I solved this problem changing resulution of my monitor, but in the game when I click on Kenji and right click somewhere on the ground game lags and sometimes crashes. Why?

Share this post


Link to post
Share on other sites

That's exactly the same problem I have and no one cared to answer o/

Maybe because it doesn't have one and your simply screwed for having a better OS to run a game that thought Windows XP would last forever.

Share this post


Link to post
Share on other sites

I have:

Windows Ultimate 7 64bit

Phenom 9850BE

XFX 750a

4GB DDR2 1066MHz

Evga 9800GTX+

Tagan BZ700W

Antec 1200

Battle Realms + WOTW

When I run BR I see only black screen with no errors. I have latest drivers for my 9800GTX+. I have this problem in Crysis too. On Vista Ultimate 64bit everything works fine.

Sorry for my bad english.

I solved this problem changing resulution of my monitor, but in the game when I click on Kenji and right click somewhere on the ground game lags and sometimes crashes. Why?

did you try installing patches? if yes, the problem is in the OS. if no, try it.

Share this post


Link to post
Share on other sites

Don't all the patches already come with the game provived by the link is some guy's signature in this forum? I think it's a 2shared link.

Share this post


Link to post
Share on other sites

Don't all the patches already come with the game provived by the link is some guy's signature in this forum? I think it's a 2shared link.

yes. if you download the game in his link (where the game is updated to the last patch), the problem is on the O.S. of the PC. try downgrading it to windows xp. do you have what's the requirements of the game?

if yes: the problem is really on the OS

if no: then put the requirements on the PC

(sorry, I don't know the requirements of the game)

Share this post


Link to post
Share on other sites

Funny thing, I have a dual-boot with Windows 7 and Ubuntu 9.10, and when I tried running the game on Wine (the Windows adapter for Linux) it worked perfectly.

Uncompatible with a latter version of its required OS but compatible with a freaking ADAPTER from a completely different OS.

Go figure.

Btw, when I got it to finally work there I tried a Direct IP game with a friend only to find out the game desyncs when a battle starts (the same way it crashes as described in the first post) and that it happens to a bunch of people. So I just gave up.

Too bad such a great game has so many issues =/

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...